Solve the Longest Common Subsequence problem.
Input Specification
Line 1:
Line 2:
Line 3:
Output Specification
Line 1: The length of the LCS of the first and second sequences.
Sample Input
Copy
5 3
1 4 3 4 2
2 1 3
Sample Output
Copy
2
Solve the Longest Common Subsequence problem.
Line 1:
Line 2:
Line 3:
Line 1: The length of the LCS of the first and second sequences.
5 3
1 4 3 4 2
2 1 3
2
Comments
This comment is hidden due to too much negative feedback. Show it anyway.
The test case can have multiple digit numbers you know
print(input())
gives9 1 1 0 2 3 10 3 0
not
9 1 1 0 2 3 1 0 3 0