Longest Common Subsequence

View as PDF

Submit solution

Points: 7
Time limit: 1.0s
Memory limit: 256M

Author:
Problem type

Solve the Longest Common Subsequence problem.

Input Specification

Line 1: N, M (1 \le N, M \le 1\,000)

Line 2: N nonnegative integers \le 1\,000, the first sequence.

Line 3: M nonnegative integers \le 1\,000, the second sequence.

Output Specification

Line 1: The length of the LCS of the first and second sequences.

Sample Input

5 3
1 4 3 4 2
2 1 3

Sample Output

2

Comments


  • -16
    bobhob314  commented on June 19, 2015, 7:32 p.m. edited

    This comment is hidden due to too much negative feedback. Show it anyway.


    • 15
      kobortor  commented on June 19, 2015, 8:04 p.m. edited

      The test case can have multiple digit numbers you know

      print(input()) gives

      9 1 1 0 2 3 10 3 0

      not

      9 1 1 0 2 3 1 0 3 0