Tudor is sitting in math class, on his laptop. Clearly, he is not paying attention in this situation. However, he gets called on by his math teacher to do some problems. Since his math teacher did not expect much from Tudor, he only needs to do some simple addition problems. However, simple for you and I may not be simple for Tudor, so please help him!
Input Specification
The first line will contain an integer , the number of addition problems Tudor needs to do. The next lines will each contain two space-separated integers whose absolute value is less than , the two integers Tudor needs to add.
Output Specification
Output lines of one integer each, the solutions to the addition problems in order.
Sample Input
2
1 1
-1 0
Sample Output
2
-1
Example Solutions
The judge is strict in expecting the output to match exactly. Do not prompt for input.
Python 2
N = int(raw_input())
for _ in xrange(N):
a, b = map(int, raw_input().split())
print a + b
Python 3
N = int(input())
for _ in range(N):
a, b = map(int, input().split())
print(a + b)
Java
import java.util.*;
public class APlusB {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
int N = in.nextInt();
for (int i = 0; i < N; i++) {
int a = in.nextInt();
int b = in.nextInt();
System.out.println(a + b);
}
}
}
C++
#include <iostream>
using namespace std;
int main() {
int N;
cin >> N;
for (int i = 0; i < N; i++) {
int a, b;
cin >> a >> b;
cout << a + b << endl;
}
}
C
#include <stdio.h>
int main() {
int N;
scanf("%d\n", &N);
for (int i = 0; i < N; i++) {
int a, b;
scanf("%d %d\n", &a, &b);
printf("%d\n", a + b);
}
}
Turing
var N, a, b : int
get N
for i: 1..N
get a, b
put a + b
end for
Algol 68
INT n;
get(standin, n);
TO n DO
INT a, b;
get(standin, a);
get(standin, b);
print((whole(a + b, 0), newline))
OD
Scala
import scala.io.StdIn
object aplusb extends App {
for (_ <- 1 to StdIn.readInt()) {
val Array(a, b) = StdIn.readLine().split(" ")
println(a.toInt + b.toInt)
}
}
Rust
#[macro_use] extern crate dmoj;
fn main() {
let n = scan!(usize);
for _ in 0..n {
println!("{}", scan!(i64) + scan!(i64));
}
}
Comments
This comment is hidden due to too much negative feedback. Show it anyway.
The Return of A Plus B is a joke problem (https://stackoverflow.com/questions/59640101/unable-to-solve-simple-dmoj-math-question), and A Minus B has been removed.
This comment is hidden due to too much negative feedback. Show it anyway.
I mean like, does it really matter? If anyone figures out a bunch of 5 pointers or above, the 3 points won't be worth much.
Ruster see this page https://github.com/DMOJ/dmoj-rust